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C-990.FA1 PI FA1 Alignment Tool 
Software for aligning optoelectronic components; for use with C-884 controller for motorized 
axes and E-727.AS controller with fast alignment routines (spiraled area scan) for piezo axes with 
strain gauge sensors. 
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About this Document 

The following company names and brands are registered trademarks of Physik Instrumente (PI) GmbH & Co. 
KG: 

PI®, NanoCube®, PICMA®, PILine®, NEXLINE®, PiezoWalk®, NEXACT®, Picoactuator®, PInano®, PIMag®, Q-
Motion® 

 
Notes on brand names and third-party trademarks: 
Microsoft® and Windows® are registered trademarks or trademarks of Microsoft Corporation in the USA 
and/or other countries. 

 
The software products provided by PI are subject to the General Software License Terms of Physik 
Instrumente (PI) GmbH & Co. KG and may contain and/or use third-party software components. Further 
information can be found in the General Software License Terms 
http://www.physikinstrumente.com/download/EULA_PhysikInstrumenteGmbH_Co_KG.pdf  
and in the Third-Party Software Notes 
http://www.physikinstrumente.com/download/TPSWNote_PhysikInstrumenteGmbH_Co_KG.pdf  
on our website. 

 
© 2024Physik Instrumente (PI) GmbH & Co. KG, Karlsruhe, Germany. The text, photographs, and drawings in 
this manual are protected by copyright. With regard thereto, Physik Instrumente (PI) GmbH & Co. KG retains 
all the rights. The use of any text, images and drawings is permitted only in part and only when indicating the 
source. 

Subject to change. This manual is superseded by any new release. The latest respective release is available for 
download on our website (http://www.pi.ws). 

The devices and software tools that are mentioned in this documentation are described in their own 
manuals. 
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Definition of Terms 

F-131.3SD1 system Photonics alignment system available from PI. Consists of three 
stacked M-111 linear stages, one three-axis P-611 NanoCube® 
nanopositioner, one C-884.4DC controller for DC motors, and one 
E-727.AS controller. E-727.AS controls the axes of the P-611 
NanoCube® nanopositioner, and C-884.4DC controls the stacked 
M-111 linear stages. 

  
Photonics Alignment The goal of photonics alignment is to align optical components—

transmitter or receiver— so that the maximum optical power is 
measured on the receiver side. During the alignment of transmitter 
or receiver in axes x, y and z, the power of the optical signal (light) 
is measured on the receiver side with a power meter. The power 
meter converts the optical power into an analog signal that is fed 
into the controllers. 

PI FA1 Alignment Tool Program name. Note that the product code for purchase orders is 
"C-990.FA1". 

Spiraled area scan An area scan is performed during photonics alignment to find the 
position of the global intensity maximum of the measured signal in 
a given area. With a spiraled scan, the motion of scan axis and step 
axis results in a spiral that covers the scan area. The start position 
is the center of the (square) scan area.  
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Function Reference  

The PI FA1 Alignment Tool allows the user to operate the F-131.3SD1 photonics alignment 
system and similar PI systems in scanning applications easily. The program makes it possible to 
configure and execute spiraled area scans. The user can choose to go to the position of the 
maximum intensity that was found or go back to the start position.  

 

 
Figure 1: PI FA1 Alignment Tool, main window 

The scan configurations can be saved to and imported from files on the PC. 

The scan results can be saved as data file or image. 

The program configuration is saved in a configuration file on the PC so that the last 
configuration is immediately available at the next start of the program. 
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Menu Bar 

 
 Connections: You can close all connections, and clear the Last Connections list in the 

Connect Devices window. 

 View: You can show the following: 

− Connect Devices window (p. 6) 

− Advanced pane in the Scan Control tab cards; gives you access to data recorder and 
timing settings for the scan (p. 13) 

− Command Entry windows for the connected controllers (p. 9) 

− Axes Control windows for the connected controllers (p. 7) 

− Analog Input windows for the connected controller (p. 9) 

 Help: You can import licenses for controllers (p. 11), show this manual and program 
version information. 

Connect Devices 

 
In the Connect Devices window, you can establish the communication between the PC and the 
controllers. 

 When you try to establish the connection to a controller for which the license has not 
yet been imported, you will obtain an "Invalid license" message. Import the license for 
the controller (p. 11). 

The Connect Devices window automatically opens at program start. You can open it again using 
the View > Show Connect Devices window menu item. 

If the controller to be connected is listed in the window, double-click its line, or mark it and click 
Connect Selected. 

 The Last Connections item lists all connections that were successfully established in the 
past. In this way, you can easily establish a previous connection again. You can clear the 
list using the Connections > Clear last connections menu item. 

If you want to use the TCP/IP interface and the controller is not listed in the window, click 
Search for Network Devices to add it to the list. 
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If the controller is not found using Search for Network Devices, but you know its IP address and 
port, click Connect … to open the Connect dialog. In the Connect dialog, go to the TCP/IP tab, 
enter IP address and port and click OK. 
If you want to reconnect the currently connected controllers at the next start of the PI FA1 
Alignment Tool, tick the Automatically connect devices on next start box. 

Axes Control 

  
The PI FA1 Alignment Tool provides an Axes Control window for each controller connected.  
The Axes Control windows by default open docked to the left-hand border of the main window. 
You can undock and dock them again by dragging them with the left-hand mouse button 
pressed. 
You can open an Axes Control window again using the View > E-727 > Show Axes Control or 
View > C-884 > Show Axes Control menu item. 
The Axes Control window is intended for the following tasks: 
 If necessary, start a reference move (axes with incremental sensors) or an AutoZero 

procedure (axes with piezo actuators): Reference… button / Auto Zero… button 
 Move the axes to their center position: Center Axes 
 Execute motion of a particular step size by clicking the arrow buttons. The step sizes can 

be configured in the Axes Control Options window. Click Configure… to open this 
window. 

 Execute motion to a certain target position by entering the target in the Target column 
of the axes table. Confirm the entry with the Enter button. 

 Assign the axes of the mechanics to the 
directions of motion (X, Y, Z; invert 
axes) as defined in your application: 
Click Configure… to open the Axes 
Control Options window. The 
assignment applies to motion started in 
the Axes Control window. The X, Y, and 
Z assignment is also shown in the Scan 
axis and Step axis selection boxes of 
the Scan Control panel.  
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Scan Control 

 
The PI FA1 Alignment Tool provides a Scan Control panel for each controller connected. Each 
panel has its own tab. 

You can arrange the Scan Control tabs in the main window of the PI FA1 Alignment Tool by 
dragging them with the left-hand mouse button pressed. 

Contents of the Scan Control panel: 

 Controls for configuration and start of scans, for details, see "Scanning for the 
Maximum Intensity" (p. 13) 

 Preview of the last configured scan 
 Tabs with 3-D and 2-D graphic representations of the scan results, for further details, 

see "Handling of Scan Results" (p. 18) 
 Panel with scan results 
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Analog Input 

  
The PI FA1 Alignment Tool provides an Analog Input window for each controller connected.  

The Analog Input windows by default open docked to the right-hand border of the main 
window. You can undock and dock them again by dragging them with the left-hand mouse 
button pressed. 

You can open an Analog Input window again using the View > E-727 > Show Analog Input or 
View > C-884 > Show Analog Input menu item. 

The Analog Input windows display the input signal as live chart, which allows the user to 
monitor the measured intensity permanently.  

You can select the input channel to be displayed. The selection has no effect on the scan 
settings in the Scan Control panel. 

Command Entry 

 
The PI FA1 Alignment Tool provides a Command Entry window for each controller connected.  

You can open a Command Entry window using the View > E-727 > Show Command Entry or 
View > C-884 > Show Command Entry menu item. 
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In the Command Entry window, you can address GCS commands to the controller. See the 
response to the HLP? command for a list of all commands supported by the controller. For 
detailed descriptions of the commands, see the user manual or commands manual of the 
controller. 

Configuration File 
The following settings of the PI FA1 Alignment Tool are automatically saved in a configuration 
file: 

 Connection settings (p. 6) 
 Axes Control window (p. 7): Axis assignment, step size for the arrow buttons  
 Scan Control panel (p. 8): Scan configuration, selection of the analog input channel 

Working with the PI FA1 Alignment Tool 
Requirements 

To work with the PI FA1 Alignment Tool, the following requirements have to be fulfilled. 

Program and Licence 

You have purchased the PI FA1 Alignment Tool from PI.  

PI has provided you with the program setup, and with a license file for each controller which is 
to be used with the program. 

PC and Communication Interface 

PC with Windows operating system (For information on the compatibility of the software with 
PC operating systems see the C-990.CD1 Release News in the root directory of the data storage 
device provided with the controller.) 

You have installed the software provided on the data carrier with PI software (e.g., dynamic 
program library for GCS, PIMikroMove). 

One of the following communication interfaces is available: 

 COM port on the PC 

 Ethernet connection in the PC or an access point in the network connected to the PC  

 USB interface on the PC 

Photonics Alignment System available from PI 

The photonics alignment system (e.g., F-131.3SD1, p. 4) functions properly. To ensure this, start 
a few motion tests of the axes in PIMikroMove. Note that for motorized axes (e.g., axes 
connected to C-884), this includes loading the parameter settings for the connected stages from 
a stage database. See the E727T0005 user manual and the user manual of the C-884 controller 
for instructions. 

Note that a new adjustment of the closed-loop performance is absolutely necessary whenever 
you change the load on the nanopositioner (which is, for example, the P-611 NanoCube®), e.g., 
by attaching, removing or replacing a fiber holder. 
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The PIMikroMove software and the user manuals are provided on the data carrier with PI 
software which is in the scope of delivery of the controllers. 

Analog Input 

The measured optical power is fed as an analog input signal into the controllers of the 
photonics alignment system. The analog signal can be in the range from-10 V to +10 V.  

 

Installing the PI FA1 Alignment Tool 
You can install the PI FA1 Alignment Tool on any number of computers. 

1. Start the installation wizard by double-clicking the Setup.exe file in the installation 
directory (root directory of the installation medium). 

The InstallShield Wizard window opens. 

2. Follow the instructions on the screen to install the program and import the licenses for 
the controllers (for details on license import, see p. 11). 

Starting the PI FA1 Alignment Tool 

1. Start the PI FA1 Alignment Tool on the PC. 
2. Establish communication with the controllers. For details, see "Connect Devices" (p. 6). 
3. If necessary, import the licenses for the controllers. For details, see "Importing 

Licenses". 

Importing Licences 

You need a license for each controller which is to be used with the PI FA1 Alignment Tool.  

If the product codes and the serial numbers of the controllers are known to PI at the time of 
purchase of the PI FA1 Alignment Tool, the license files are available on the installation medium 
and can be imported immediately after the program installation has finished. 

If you want to get a licence file for another controller: 

 Contact your PI sales engineer or our customer service department (p. 21). Have the 
product code and the serial number of the controller ready. 

Import the license file (serialnumber_productcode.pilic) for the controller as follows: 

1. Open the Import PI license file window: 

− Use the Help > Import License … menu item at any time. 

− When you establish a connection to the controller for the first time in the PI FA1 
Alignment Tool: Confirm the "Invalid license" message with OK. 

2. In the Import PI license file window, go to the directory where the license file (file 
extension .pilic) for the controller is located. 

3. Double-click the file, or mark it and click Open. 

The PI FA1 Alignment Tool imports the license. 

You can import an unrestricted number of licenses into the program, but only one E-727.AS 
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controller and one C-884 controller can be used at a time. If you have more controllers, use 
multiple instances of the program. 

Configuring Axes and Analog Input 

The configuration settings for axes and analog input are automatically saved in the 
configuration file (p. 10) so that they are immediately available at the next start of the PI FA1 
Alignment Tool. 

1. Click Configure… in the Axes Control windows (p. 7) to open the Axes Control Options 
window. 

a) Assign the axes of the mechanics to the directions of motion (X, Y, Z) as defined in 
your application. Note that the settings in the Invert boxes apply only to motion 
started using the controls in the Axes Control windows. 

b) Set the step sizes for motion that is triggered with the arrow buttons in the Axes 
Control windows. 

2. For each controller, select the analog input channel to be used via the Analog input 
selection button in the Scan Control panel. The selection also applies to the Analog 
Input windows (p. 9). 

Optional: Starting Motion Manually 

 NOTICE 

 

Collisions between optical components and surroundings 
Collisions can damage the optical components to be aligned, and the surroundings. 

 When using the controls in the Axes Control windows to move the axes, watch the axis 
motion to avoid collisions. 

 Keep in mind that the axes use different units of length for position values (target, current 
position): 
− Piezo-driven nanopositioners, e.g., P-611 NanoCube® (E-727.AS): µm 
− Motorized positioners, e.g., stacked M-111 linear stages (C-884): mm 

Proceed as follows if you want to move the axes manually, for example, before or instead of 
using scans: 

1. If necessary, start a reference move (axes with incremental sensors) or an AutoZero 
procedure (axes with piezo actuators) using the Reference… button / Auto Zero… 
button in the Axes Control windows. 

2. Move the axes using the controls in the Axes Control windows (p. 7) towards the 
position where you expect the maximum intensity of the optical power and hence the 
maximum value of the analog input signal. When moving, watch the live charts in the 
Analog Input windows. The greater the voltage values, the greater the measured 
intensity. You have the following options for motion: 

− Move the axes to their center positions: Center Axes 

− Execute motion of a particular step size by clicking the arrow buttons 
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− Execute motion to a certain target position by entering the target in the Target 
column of the axes table. Confirm the entry with the Enter button. 

 

Scanning for the Maximum Intensity 

 

 NOTICE 

 

Collisions between optical components and surroundings 
Collisions can damage the optical components to be aligned, and the surroundings. 

With a spiral scan, the motion of scan axis and step axis results in a spiral that covers the 
square scan area. The start position is the center of the scan area. 

 Configure the scans so that collisions are not possible. In particular, enter suitable values 
for 
− Scan range 
− Center position of the scan 

 Keep in mind that the axes use different units of length for position values (target, current 
position): 
− Piezo-driven nanopositioners, e.g., P-611 NanoCube® (E-727.AS): µm 
− Motorized positioners, e.g., stacked M-111 linear stages (C-884): mm 

 

Configuring and Running Scans 
Configure and run scans as follows: 

1. If necessary, start a reference move (axes with incremental sensors) or an AutoZero 
procedure (axes with piezo actuators) using the Reference… button / Auto Zero… 
button in the Axes Control windows. 

2. Configure the spiraled area scans in the Scan Control panels (figure, see p. 8): 

a) Select the axes involved in the scan: Scan axis, Step axis 

b) Make sure that the proper analog input channel is selected: Analog input 

c) Specify the side length of the square scan area: Scan range 

d) Specify the start position of the scan (= center of the scan area): Scan axis center, 
Step axis center 
Click the  buttons if you want to use the current positions of the axes.  

e) Specify the separation distance between the successive turns of the spiral: Line 
spacing 

f) Specify the velocity for the scan. 

 E-727: The velocity is the product of separation distance and frequency. Specify 
the Frequency in Hz.  
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 C-884: Path velocity 

 

 
The figures show the default settings of the PI FA1 Alignment Tool that are present 
when you run the program for the first time. 

The configuration settings for the scans are automatically saved in the configuration file 
(p. 10) so that the last used settings are immediately available at the next start of the PI 
FA1 Alignment Tool. 

You can also export scan configurations to files on the PC and import them later (p. 17). 

3. Optional: Check the settings for data recorder and trajectory timing (C-884 only). 

a) Show the Advanced pane in the Scan Control panels using the View > Show 
advanced features menu item.  

b) Check the Data Recorder Record Rate entry in the Advanced pane. The value 
specifies the number of servo cycles before the recording of one data point. The PI 
FA1 Alignment Tool automatically optimizes the value when you configure a scan. 
You can change the value, but keep in mind that with a too high record table rate 
the maximum may not be precisely found, while with a too low record table rate 
the data recorder may be full before the axes have covered the scan area 
completely. 

c) In the Scan Control panel of C-884, click Estimate in the Advanced pane to check 
the trajectory timing for the scan.  

4. Start the scan.  

a) In the Position After Scan pane, select the position to be approached by scan axis 
and step axis when the scan has been completed. Default and recommended: Move 
to maximum position. 

b) C-884 only, recommended: Tick the Center axes of E-727.AS before scan box. 
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c) Click the Start Scan button to start the scan. 
While a scan is running, it is not possible to start a second scan. 

 
5. Check the scan results. 

The Scan Results pane displays the position and the value of the found maximum. 

 
The 3D and 2D tabs show graphic representations of the scan results. 

You can change the display properties and export the scan results to an image or data 
file using the toolbar buttons on the 2D tab; for details, see p. 18. 

The following figures show examples for scan results. 

  
Figure 2: Scans performed by the stacked M-111 linear stages connected to the C-884 

controller; maximum was not found (left-hand figure) / maximum was found 
(right-hand figure) 

   
Figure 3: Scans performed by the P-611 NanoCube® nanopositioner connected to the E-

727.AS controller; maximum not found, and slew rate too low (left-hand figure) / 
maximum not found, and slew rate ok (middle figure) / maximum was found 
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(right-hand figure) 

Optimizing the Scan Procedures 
There is no universal 'best' approach to aligning an arbitrary device. There is, however, a best 
practice: exploratory experimentation. Here are some tips. 

Iterative process 
Finding the global intensity maximum is an iterative process. It is more likely to capture the 
global maximum precisely with the next scan when it starts at the maximum found with the 
previous scan. 

1. Perform a scan with Move to maximum position selected so that the axes are at the 
position of the found maximum afterwards. 

2. Use the  buttons to specify the current position as the start position (center) of the 
next scan. 

3. Start a new scan. 

E-727.AS: Slew rate setting 
With E-727.AS, the velocity required for a spiraled scan is the product of the specified 
separation distance in µm (Line spacing) and frequency in Hz (Frequency). The maximum 
permissible velocity for the axes is given in µm/s by the Servo Loop Slew-Rate parameter (ID 
0x07000200) of the E-727.AS. Make sure that the slew rate is set high enough for the axes 
involved in the scan. 

1. Open the Command Entry window (p. 9) using the View > E-727 > Show Command 
Entry. 

2. Query the slew rate settings for axes 1, 2 and 3 with the following commands: 
− SPA? 1 0x07000200 
− SPA? 2 0x07000200 
− SPA? 3 0x07000200 

3. If the response shows that the slew rate is too low, increase it with the following 
commands (settings are made in volatile memory), where slewrate specifies the 
new slew rate setting: 
− CCL 1 advanced 
− SPA 1 0x07000200 slewrate 
− SPA 2 0x07000200 slewrate 
− SPA 3 0x07000200 slewrate 

Considering the Mechanics Lifetime 
In terms of the mechanics lifetime (and, of course, also in terms of the scan optimization), you 
should consider some general recommendations: 

You should solve the alignment tasks as far as possible using the axes of a piezo-driven 
nanopositioner (e.g., P-611 NanoCube®). With the nanopositioner, in contrast to motorized 
drives, there are no rotating parts or friction. The piezo actuators are therefore free of backlash, 
maintenance, and wear. In addition, the flexure guides of a nanopositioner are maintenance 
and wear free. 
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Use motorized stages (e.g., M-111 linear stages) only for the rough optimization. Keep in mind 
that with motorized axes, frequent motions over a limited travel range can cause the lubricant 
to be unevenly distributed in the drive train: 

 For motorized axes, carry out a maintenance run over the entire travel range at regular 
intervals (see documentation of the mechanics). The more often motions are carried 
out over a limited travel range, the shorter the time between the maintenance runs has 
to be. 

Export / Import of Scan Configurations 

You can export scan configurations to files on the PC and import them later at any time. 

The exported data can also be imported on the Area Routines tab in PIMikroMove, and area 
routine configurations exported from PIMikroMove can be imported in the PI FA1 Alignment 
Tool. 

Export the Current Scan Configuration 
 Click the Export … button on the Scan Control panel, enter a name for the scan and 

save the scan configuration to a .dat file. 

− Make sure to use unique names for the scans, especially if you want to save 
multiple scan configurations to the same file. 

Note that the PI FA1 Alignment Tool automatically adds fixed values for the following 
settings to every scan configuration: 

− Minimum intensity threshold of the analog input signal 

− Target type of the scan 

− Estimation method for the position of the global intensity maximum  

− Minimum and maximum intensity to be used for estimation 

Import a Scan Configuration 
 Click the Import … button on the Scan Control panel, select a .dat file and the scan to be 

imported. 

Note that when importing a scan configuration created in PIMikroMove, the PI FA1 
Alignment Tool ignores the values for the following settings: 

− Minimum intensity threshold of the analog input signal 

− Target type of the scan 

− Estimation method for the position of the global intensity maximum  

− Minimum and maximum intensity to be used for estimation 
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Handling of Scan Results 

The Scan Control panels contains 3D and 2D tabs for the scan results. 

The 3D tab simply shows a 3-D graphic representations of the results. Rotate the view by 
dragging the mouse pointer across the tab with the left-hand mouse button pressed. Zoom in or 
out on the view by dragging the mouse pointer across the tab with the right mouse button 
pressed. 

The 2D tab offers various functions via its toolbar. 

 

 

 

 

 
 

Read the tooltips for short descriptions of the tools. 

This manual describes the tools for configuration of the display properties (p. 19) and 
export/import of scan results (p. 20). 

You can find detailed descriptions of the other tools in the “Configure Graphics Pane" section of 
the PIMikroMove manual (SM148E).  
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Configure Display Properties of the 2D Tab 

Open the Display Properties window with the toolbar button of the 2D tab. 

In the Display Properties window, you can define the curves to be displayed on the 2D tab. 

The upper pane of the window shows lists of the recorded data. The table below contains the 
curve definitions. 

 
You can add curves to the display: 

1. Select the desired data in the Data for X list. 
2. Select the desired data in the Data for Y list. 
3. Click the Add to Y Axis or Add to Y2 Axis button to add the curce to the curve table and 

therefore to the display. It is recommended to assign any data whose range is greatly 
different from that of other data to the second Y-axis in the graphics pane. 

You can remove curves from the display: 

 Hide a curve by removing the check from its Show box in the curve table. 
 Delete a curve using the Delete entry of its context menu in the curve table. 

Furthermore you can set the color and the appearance of data points and lines in the display for 
every single curve. 

You can enter title and labels for the display at the bottom of the Display Properties window. 
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Export the Scan Result 
The scan result can be saved on the PC using the toolbar buttons of the 2D tab: 

 Click  "Export data as data file": Save the scan result by exporting the recorded 
data as "comma separated values" (.csv format, e.g. for MS Excel) or in GCS Array 
format (see GCS Array manual, SM146E). If you want to load the data to the 2D tab 
later, you must save it in GCS Array format. 

 Click  "Save image as graph": Save the graphic representation of the scan result as 
.png or .bmp file. 

Import Scan Results 
You can load data to the display using a toolbar button of the 2D tab: 

 Click  "Import data": Import data from GCS Array .dat files on the PC. 
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Troubleshooting 

Fault: Communication with the controller does not work 

Possible Causes Remedial measures 

The wrong 
communication cable 
is used or it is 
defective 

 If necessary, check whether the cable works on a fault-free system. 

The power-on/reboot 
sequence had not 
finished 

 Wait until the starting procedure of the controllers has finished before you try 
to establish communication. 

The interface is not 
configured correctly 

 With the RS-232 interface, check port and baud rate. 
When using the TCP/IP connection: 
 Connect the controller to the network before you switch it on. Otherwise, you 

will have to switch the controller off and on again. 
 Check the network settings (for details, see the user manual of the controller). 
 Make sure that the network is not blocked for unknown devices. 
 Make sure that several PC software applications cannot access a controller at 

the same time. 
 Make sure that you have selected the correct controller when establishing 

communication. 
 If you cannot solve the problems, consult your network administrator if 

necessary. 

Another program is 
accessing the 
interface. 

 Close the other program. 

Problems with the PI 
FA1 Alignment Tool 

 Check whether the system works with other software, such as a 
terminal program or a PIMikroMove.  

 Test the communication by sending the *IDN? or HLP? command. 

 

Fault: "Invalid license” message appears when you try to establish a connection to the controller 

Possible Causes Remedial measures 

License for the 
controller is missing 

 Import the license file for the controller, for details, see p. 11. 
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Fault: The scan result is not satisfactory. 

Possible Causes Remedial measures 

Input signal faulty or 
not available 

 Check the light source. 

 Check the cables and connections. 

 Check if the proper input channel is selected in the PI FA1 Alignment Tool. 

 Check if the analog signal is in the range from -10 V to +10 V. 

Unsuitable settings for 
the scan 

 Check if Line spacing is appropriate to your signal width. 

 Check if the velocity fits to the mechanics performance. 

Unsuitable settings of 
the notch filter and 
the servo-control 
parameters 

 A new adjustment of the closed-loop performance is absolutely necessary 
whenever you change the load on the P-611 NanoCube® nanopositioner, e.g., 
by attaching, removing or replacing a fiber holder. See the E727T0005 user 
manual and the user manual of the C-884 controller for instructions. 

E-727.AS: Slew rate 
too low 

Spiral is deformed / whole scan range is not reached: 
 Increase the slew rate of the axes, for details, see p. 16. 

E-727: Sensor zero 
point is not set 
correctly 

Changes in temperature or changes in the mechanical load can cause small 
deviations of the sensor zero point. When the sensor zero point is not set correctly, 
the complete output voltage range of the amplifier cannot be used in closed-loop 
operation. 
 Start an AutoZero procedure in the Axes Control window for E-727.AS. 

Unsuitable data 
recorder record rate 

1. Show the Advanced pane in the Scan Control panels using the View > Show 
advanced features menu item.  

2. Check the Data Recorder Record Rate entry in the Advanced pane. The value 
specifies the number of servo cycles before the recording of one data point. The 
PI FA1 Alignment Tool automatically optimizes the value when you configure a 
scan. You can change the value, but keep in mind that with a too high record 
table rate the maximum may not be precisely found, while with a too low 
record table rate the data recorder may be full before the axes have covered 
the scan area completely. 

 

Fault: No motion of the axes. 

Possible Causes Remedial measures 

The F-131.3SD1 
system does not 
function properly. 

 Start a few motion tests of the axes in PIMikroMove. 
 C-884: Make sure that you have loaded the proper parameter settings for the 

motorized axes from a stage database in PIMikroMove. 

C-884: Reference 
move required 

For axes with incremental position sensor, absolute target positions can be 
commanded only if the reference point for the axis has been defined beforehand. 
 Start the reference moves in the Axes Control window for C-884. 
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Customer Service 

For inquiries and orders, contact your PI sales engineer or send us an email 
(mailto:service@pi.de). 

 If you have questions concerning your system, have the following information ready: 

− Product and serial numbers of all products in the system 

− Firmware version of the controller (if available) 

− Version of the driver or the software (if available) 

− Operating system on the PC (if available) 

 If possible: Take photographs or make videos of your system that can be sent to our 
customer service department if requested. 

The latest versions of the user manuals are available for download (http://www.pi.ws) on our 
website. 
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